おとてく

おとてく

作曲家/レコーディングエンジニア。フリーランスでギリギリ生きていけてる33歳が書くメディア。

EastWestのPLAYエンジンが音色ライブラリを読み込まなくなった!→解決までの流れ

EastWestのPLAYエンジンというのは、プレイバックサンプラー*1の一種です。 

プレイバックサンプラーとしては、Native InstrumentsのKontaktや、SteinbergのHALionなども有名ですね。

 

とかいう前置きはいいとして、本題!

そのPLAYというプレイバックサンプラーがトラブっちゃったんです!

 

 

PLAYを使おうとするとCubaseが落ちるようになった!

僕は2010年からPLAYを使っているんですが、初めて大きなトラブルに出くわしました。

f:id:oto_tech:20170820214741j:plain

音色ライブラリを読み込もうとするとCubaseが落ちる!

1つ目のトラブルはこれ。

PLAYには、オーケストラ音源だったり、民俗楽器音源だったり、様々な音色データがあるのですが、

その音色を読み込もうとすると、ホストアプリケーションであるCubaseが落ちるようになってしまったんです!

 

古い曲データでも、PLAYを使っているものは開けない!

さらに、2つ目のトラブル。

過去に制作した曲のデータ(プロジェクトファイル)でも、PLAYを使っているものは開けなくなってしまったんです!

正確に言うと、開こうとするとCubaseが落ちるという状況。

 

これが大問題。

僕の曲の9割は、どこかしらでPLAYを使っているんです。

つまり過去のプロジェクトの9割は開けない!

パラデータ納品が迫っているものもあったので、大ピンチ!です。

 

  

解決の為に自分でやってみたこと

まず自力で色々試しました。

ただ、先に言っておきますが、ここに挙げる方法では解決しませんでした

f:id:oto_tech:20170820220620j:plain

PLAYエンジンをアップデート

僕の使っていたPLAYエンジンは4.2.25というバージョンだったので、これを4.3.3にマイナーアップデートしてみました。

ちなみに現時点でバージョン5がリリースされていたのですが、OS等の対応可否も確認していなかったので、とりあえずメジャーアップデートは避けました。

 

Cubase初期設定ファイルのリセット

DAWは、起動する際にテンプレートなどの様々なデータ(初期設定ファイル)を読み込みます。

初期設定ファイルのリセットとは、このデータを一旦リセットして、Cubaseを初めてインストールした時と同じ状態に戻すことを言います。

DAWでなにかトラブった時には、まずこれを試すという人も多いと思います。

 

初期設定ファイルのリセット方法はこちらを参照

【Cubase Pro/Artist 8.5】Windows 7環境における「初期設定ファイルのリセット」方法を教えてください。 - ヤマハ

 

で、これらの方法では残念ながら解決しませんでした。

  

スポンサーリンク
 

 

その後、無事解決!そこに至るまでの流れ

f:id:oto_tech:20170820231249j:plain

バージョン5にアップデート

自分ではお手上げだったので、代理店のサポートに問い合わせました。

 

すると、「ひとまず最新バージョンであるPLAYの5.0.4にアップデートしてみて、動作確認を行ってください」という回答。

OS(Win7)等、動作要件はPLAY5でも満たしていたようなので、言われたとおり、PLAY5をダウンロード、インストールしました。

 

バージョン5にアップデートした結果・・・

・PLAYの音色ライブラリを読み込めない→解決!

・PLAYを使っている過去の曲を開けない→未解決のまま

 

と、まず半分だけ解決

 

で、このとき、新PLAY(5.0.4)をインストールした後も旧PLAY(4.3.3)が残ったままになってました。 

古い方は勝手にアンインストールされるかと思っていたのですが、そうではなく、

新旧が混在している状態です。

 

なので、Cubase上でも新PLAYと旧PLAYが両方選べる状態。

旧PLAYの方を立ち上げると、やはり音色ライブラリを読み込んだ時点でCubaseが落ちると言うのは変わらずでした。

でも、これから新しく作る曲に関しては、新PLAYの方を使えばいいので、ひとまずそちらは解決。

 

あとは、過去の曲を開けるようにするだけ!なんですが、

この段階で、再度サポートに問い合わせても返答無し!笑

いつまでも待つわけにいかないので、自力でなんとかしてみようと頑張りました。

 

古いバージョンをプラグインフォルダから移動

とりあえず、旧バージョンに何らかの異常が起きたのは間違いない。

そこで試してみたのが、「旧バージョンのDLLファイル(プラグインの本体みたいなもの)を別のフォルダに移す」という方法。

「曲データを開く時に旧PLAYが見つからなければ、自動的に新PLAYを読み込みにいくんじゃないか」という気がしたんです。

 

旧バージョンのDLLファイルを別のフォルダに移した結果・・・

・PLAYの音色ライブラリを読み込めない→解決!

・PLAYを使っている過去の曲を開けない→解決!

はい!両方OK!無事に過去の曲データを開くことが出来ました

 

ただ、「自動的に新PLAYを読みにいく」という仮説はハズレで、やっぱり変わらず旧PLAYを読み込んでました。

でも問題は起きず。

 

プラグインフォルダを変更したことで、旧バージョンの異常のあった部分がリセットされたのではないか?というのが僕の仮説です。

 

原因がハッキリとはしないのがちょっと気持ち悪いですが、

なんにせよ無事に解決したので良かったです。

 

ちなみに

PLAYの最新バージョンである5ですが、音色ライブラリの読み込みスピードが格段にアップしてます!

今まではかなり遅くて、これが結構なストレスだったんです。

偶然の産物ですが、そこも解決されました。

まさに、災いを転じて福となす!というやつですね。

 

 

この記事を書いた人のTwitterはこちら。 

*1:「プレイバックサンプラー」とは、サンプリングされた音色データを音源として利用できるツールで、自分で音をサンプリングするところからスタートする「サンプラー」とは違います。

(まぁ割とごっちゃになって使われている言葉ではありますけど)